Exchange - Stability Issues
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 16:12 UTC
Update
We are aware that a number of customers are still experiencing issues when trying to navigate or place trades on the exchange. Our team have identified the problem and are working hard to restore stability to all customers.

Thank you for your continued patience.
Posted Jan 03, 2021 - 22:01 UTC
Investigating
A small number of customers are reporting difficulty navigating pages within the exchange or issues with some trades failing to place.

Our team are investigating this now and we hope to resolve this as fast as possible.

We are sorry for any inconvenience this may cause you, and we will update the message as soon as further information becomes available.

Thank you for your patience.
Posted Jan 03, 2021 - 18:29 UTC
This incident affected: The Exchange (Exchange).