Balance display issues
Incident Report for Blockchain
Resolved
We have identified the cause of this problem and deployed a fix. All customers who were impacted by this incident should now be able to view price data as normal.

We will continue to monitor platform stability.

Thank you for your patience during this time.
Posted Aug 17, 2021 - 19:37 UTC
Identified
We are currently investigating reports of balances not displaying correctly across our product range. This is a visual issue only, and may impact the way your balance is displayed. This is also impacting some price charts.

All customers funds remain safe, and these discrepancies are a display issue only and do not impact the sum of crypto or fiat stored within your wallet.

We are sorry for any inconvenience this may cause, and our team are working to resolve this issue as fast as possible.

Thank you for your patience.
Posted Aug 17, 2021 - 14:46 UTC
This incident affected: The Exchange (Exchange) and Explorer, Wallet.