Google Cloud Outage
Incident Report for Blockchain
Resolved
The issue causing downtime has been resolved. Please let us know if any downtime related issues persist. We apologize for any inconvenience.
Posted about 1 month ago. Jul 17, 2018 - 20:27 UTC
Monitoring
We're experiencing downtime due to a global Google Cloud outage. We apologize for the inconvenience and will keep you updated as we find out more information
Posted about 1 month ago. Jul 17, 2018 - 20:04 UTC
This incident affected: Explorer and API and Wallet.