Wallet Maintenance
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted over 1 year ago. Apr 27, 2018 - 07:27 EDT
Update
Maintenance complete. Thanks for your patience.
Posted over 1 year ago. Apr 27, 2018 - 06:04 EDT
Investigating
We are performing scheduled maintenance on our wallet and will be back online shortly.
Posted over 1 year ago. Apr 27, 2018 - 04:22 EDT
This incident affected: Wallet, Wallet - Bitcoin, and Wallet - Ether.