Connectivity issues
Incident Report for Blockchain
Resolved
All systems are working. We are actively monitoring the current status.
Posted about 1 year ago. Sep 09, 2017 - 10:24 UTC
Investigating
We are currently investigating connectivity issues with our web platform.
Posted about 1 year ago. Sep 09, 2017 - 10:24 UTC