Connectivity issues
Incident Report for Blockchain
Resolved
All systems are working. We are actively monitoring the current status.
Posted over 1 year ago. May 26, 2017 - 09:58 UTC
Investigating
We are currently investigating connectivity issues with our web platform.
Posted over 1 year ago. May 26, 2017 - 09:54 UTC