Email delivery and authorization
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 25, 2019 - 13:41 EDT
Update
The issue causing a delay in email and SMS delivery has been resolved.
Posted 5 months ago. Apr 25, 2019 - 13:23 EDT
Investigating
We are currently investigating an issue with a delay in email delivery and authorization. 2FA sms code delivery is also affected. Updates to follow. Thank you for your patience.
Posted 5 months ago. Apr 25, 2019 - 09:25 EDT
This incident affected: Wallet.