Balance Display Issues
Incident Report for Blockchain
Resolved
All instances have now been restarted and balances are updating as expected.

Thank you for your patience.
Posted Oct 29, 2020 - 16:03 UTC
Identified
We are aware that some customers are experiencing balance update issues within their wallets.

Our team are working hard to fix this display issue, and this will not impact the safety of customers funds in any way.

Customers can expect some display issues when viewing Bitcoin balances within the wallet. This may include balances not loading, or transaction history failing to load and is also impacting our block explorer pages.

We are restarting multiple instances now, and once our servers catch up balances being displayed will return to normal along with transaction history.

Any transactions that have been broadcast to the network during this incident will be processed as normal and balances will appear as they should once this issue has been resolved.

We are sorry for any inconvenience this has caused, and would like to thank customers for their patience during this incident.
Posted Oct 29, 2020 - 15:45 UTC
This incident affected: Explorer and Wallet.