Bitcoin Cash fork
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted 15 days ago. Dec 04, 2018 - 16:33 UTC
Update
BCH services have safely resumed on web, with BCH representing Bitcoin Cash ABC. Mobile apps to follow.
https://blog.blockchain.com/2018/12/03/bch-service-will-resume/
Posted 15 days ago. Dec 04, 2018 - 16:29 UTC
Investigating
We're suspending BCH services in light of upcoming network instability. Your funds are safe and we'll be bringing service back as soon as possible
https://blog.blockchain.com/2018/11/14/the-bch-hard-fork/
Posted about 1 month ago. Nov 15, 2018 - 14:40 UTC
This incident affected: Wallet - Bitcoin Cash.