Intermittent Wallet Outage
Incident Report for Blockchain
Resolved
Our team have successfully restored access to all affected customers, and all wallet services are restored.

We are sorry for any inconvenience caused.
Posted Dec 16, 2020 - 21:59 UTC
Investigating
We are aware that some customers are experiencing difficulty logging into their Blockchain.com wallets. Our team are aware and are working to resolve this.

All funds are safe and secure.

We are sorry for any inconvenience this may have caused.
Posted Dec 16, 2020 - 21:08 UTC
This incident affected: Wallet.