Instability across our core services
Incident Report for Blockchain
Resolved
We have identified the cause of the system instability and deployed a fix. All products are once again performing as expected and all services have resumed.

Thank you for your patience whilst we carried out this work.
Posted Jul 29, 2021 - 00:16 UTC
Update
Customers should now be able to log into the wallet and exchange, but we are still experiencing instability that may prevent customers from placing buy, sell or swap orders and price charts may display inaccurately.

Our team are working to identify the root cause and resolve this as fast as possible.

We would like to thank our customers for their patience, and we will provide further updates as soon as they become available.
Posted Jul 28, 2021 - 21:34 UTC
Update
We are aware that a number of our products are experiencing severe instability. We are investigating the cause, and would like to reassure customers that funds stored within the wallet, Interest and exchange products remain secured.

We will provide further updates when they become available.
Posted Jul 28, 2021 - 19:42 UTC
Investigating
We are noting significant instability in exchange, explorer and custodial wallet services. We are investigating the root cause.
Posted Jul 28, 2021 - 19:06 UTC
This incident affected: The Exchange (Exchange) and Explorer, Wallet.