Delayed Withdrawals
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Aug 25, 2020 - 11:24 UTC
Identified
We are aware that some customers are still experiencing delays when trying to withdraw from the wallet. Our team are working hard to resolve this and we will provide a further update as soon as possible.

We are sorry for any inconvenience this may have caused you.
Posted Aug 24, 2020 - 11:21 UTC
Update
We are aware that customers may be experiencing delays when making withdrawals from the Wallet and we are working to resolve this. Any outstanding transactions will be cleared as soon as possible. Thank you for your patience.
Posted Aug 24, 2020 - 01:11 UTC
Investigating
We are aware that customers may be experiencing delays when making withdrawals and we are working to resolve this. Any outstanding transactions will be cleared as soon as possible. Thank you for your patience.
Posted Aug 23, 2020 - 22:04 UTC
This incident affected: The Exchange (Exchange) and Wallet.