Degraded Email Delivery
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 08, 2017 - 15:16 UTC
Investigating
We are investigating an issue related to degraded email delivery rates affecting some users.
Posted 6 months ago. Dec 07, 2017 - 15:01 UTC