Intermittent stability issues (Exchange)
Incident Report for Blockchain
Resolved
This incident has been resolved and the exchange is performing as expected for all customers.

Thank you for your patience during this time.
Posted Jan 10, 2021 - 13:36 UTC
Investigating
We are experiencing a very high increase in traffic on the exchange. Trading services are operating as normal but customers may experience small windows of instability. We are monitoring this situation and will continue to update customers should anything change.
Posted Jan 08, 2021 - 13:07 UTC
This incident affected: The Exchange (Exchange).