Maintenance on the Exchange platform
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted Jun 05, 2020 - 00:43 UTC
Monitoring
We will pause trading and withdrawals on the Exchange to perform system maintenance beginning at 20:00 GMT and we expect the pause to last about 3 hours. Customer funds will not be affected. We hope it will only be a short interruption and apologize for any inconvenience.
Posted Jun 04, 2020 - 18:38 UTC
This incident affected: The Exchange (Exchange, .com).