Database Outage
Incident Report for Blockchain
Resolved
The database issue has been resolved. All services are operating normally. We apologize for the inconvenience.
Posted 6 months ago. Nov 20, 2017 - 15:16 UTC
Identified
We are experiencing an outage of our internal database which serves bitcoin blockchain data to our explorer and wallet products. We've identified the issue and are working on a resolution. Your funds are safe. Data relating to wallets is unaffected.
Posted 6 months ago. Nov 20, 2017 - 14:33 UTC