Extended Maintenance
Incident Report for Blockchain
Resolved
We have completed maintenance on the exchange and all services have been restored.

We would like to thank you for your patience during this work.

Thank you for choosing Blockchain.com
Posted Oct 06, 2020 - 13:04 UTC
Identified
We have encountered some technical issues during a routine maintenance check. Our team are working hard to resolve these now and bring trading back online.

We are sorry for any inconvenience this may cause, and will provide a further update as soon as possible.
Posted Oct 06, 2020 - 11:25 UTC
This incident affected: The Exchange (Exchange).