BCH trading has been temporarily disabled
Incident Report for Blockchain
Resolved
This incident has been resolved.
Posted 4 months ago. May 15, 2019 - 13:06 EDT
Identified
Earlier today Bitcoin Cash (BCH) underwent a hard fork (network upgrade). We have disabled trading BCH until the network stabilizes. Updates to follow. Thank you for your patience 🙏
Posted 4 months ago. May 15, 2019 - 11:44 EDT
This incident affected: Wallet - Bitcoin Cash.