Network Instability
Incident Report for Blockchain
Resolved
The Bitcoin network has stabilized. Outgoing bitcoin transactions have been re-enabled.
Posted 10 months ago. Nov 17, 2017 - 13:14 UTC
Monitoring
The Bitcoin network is currently unstable. To continue protecting your funds, we are briefly suspending all outgoing bitcoin transactions. We anticipate restoring full service to your wallet within the hour.
Posted 10 months ago. Nov 17, 2017 - 12:46 UTC